Unable to submit release after Quality Check

Hi there!

Hopefully, this is a quick fix, but I’m having issues re-submitting a release after the quality check.

Yesterday, I got a release back with some Release Issues due to some fields that didn’t save properly. I’ve since updated the text, and everything looks good; however, I can’t click the “submit” button.

This release was initially published and paid for last year but had some additional issues that only recently got resolved. (Check the email support history on my email address for further context.)

What do I need to do to finish publishing the release?

I appreciate any help. Thanks so much!

hi @hey_maurice I’m tagging @Melani who might be able to help you with these issues :v:


Thanks, @Andi. I believe Melani was the one who responded to my last support email. So that’s perfect.

Thank you for the help. :pray:t4:


Hola @Andi and @hey_maurice , taking it from here!

Ow hi Maurice, many thanks for reaching out here and welcome to our Community!
So, yeah, our quality team has found some mistakes and I can see you filled the fields out. However, there is an additional action from your side that needs to be taken:

Please access to the dashboard and click on Release Issues on the bottom left. Click on each track and scroll down until you see the little information box. In order to submit the corrections, you need to tick the square boxes. This for each track!

After that, you will have the confirmation and the final Submit button :slight_smile:
Hope this helps and fingers crossed!

1 Like

Hi, @Melani!

Thanks for the fast reply. I appreciate the help.

SO… I’ve checked off all of the boxes but the submit button is still greyed out.

I feel like this is “operator error” but I have NO idea what I’ve missed. :sweat_smile:

Any ideas?

Here’s what the release still says at the bottom next to the Submit button:

Hey @hey_maurice, I forwarded the request to our delivery team and hopefully we’ll proceed with the release! :slight_smile:

1 Like

Thank you, @Melani !


Hey there. I have the same Problem. I checked all the boxes and I am still not able to click to submit. Did you find the solution yet?

Hey @Rolf

thank you for your message.

@Melani or @Maurizio from the iMusician Team will be in touch with you next week.

Best regards,

1 Like

@hey_maurice and @Rolf

Hello there!
Just curious: did you write the legal name of your lyricist (or of any other contributor)? Because that’s where the problem is standing from what I can see on the screenshot.

1 Like

Hey @Rolf,

you only need to check the box to confirm you made the modifications requested.
Here’s a quick gif to show you what I mean :slight_smile:

Field update request

1 Like

Hoi Maurizio

That is what I did on all of the four Tracks and also with the second Release. But after checking the boxes I was still unable to “abschicken” or submit.

1 Like

Hello @Rolf , how are you?
I checked your releases and I see you still need to tick the little boxes to submit the corrections. Please do it for each track :slight_smile:
At the end, you will be receiving the confirmation and the system will ask you to agree on the submitted corrections!
Fingers crossed!


Hello everyone.

Sorry Melani, I took over this thread and didn’t inform you about what I did in the meantime… my bad!!
It looks like there is a small bug that I reported to our tech wizards. This should get sorted pretty quickly. I’ll post some updates asap


I tried into the blue. I could submit one of my releses. The other one still won’t work.

1 Like

hi there,

I’m also in the same boat as Rolf. I’m following the instructions as suggested, but the ‘submit’ button is still greyed out.

Definitely seems like a bug.

1 Like

Hey @Rolf,

Don’t Get Me Wrong is missing the lyricist. Once you fix that, it should be all good to go :slight_smile:


Your release is a cover but the Composer/lyricist/Publisher are wrong.

I suggest you to check a collective society database, like this one, then fix the issues.

Do not forget to check the checkbox when you are done:



I really missed that. Great! It worked! Thanks.


Hi M, I’ve filled out the correct info but I still can’t hit submit, despite ticking the checkbox. Any further help you can offer?